Orion - SMS MT Delivery Checks Display Issue – Incident details

All systems operational

SMS MT Delivery Checks Display Issue

Resolved
Degraded performance
Started 16 days agoLasted 21 minutes

Affected

Orion

Degraded performance from 11:45 PM to 12:05 AM

Platform

Degraded performance from 11:45 PM to 12:05 AM

Updates
  • Resolved
    UTC
    Resolved

    This issue has been resolved. The SMS status checks on the Orion platform are now displaying correctly. As noted, SMS delivery remained fully operational throughout — the impact was limited to the visual confirmation.

    Thank you for your patience.

  • Investigating
    UTC
    Investigating

    Dear Customers,

    We are aware of an inconsistency affecting the SMS delivery checks displayed on the Orion platform.

    Please note this is a visual issue, only SMS delivery is fully operational and messages are being sent and received correctly. The impact is limited to the visual confirmation of both checks, which may not reflect the actual (working) status.

    Our team is actively investigating, and we will provide an update as soon as the display is restored.