Orion - 01-02 IMSI Service Degradation – Incident details

All systems operational

01-02 IMSI Service Degradation

Resolved
Degraded performance
Started 5 months agoLasted about 3 hours

Affected

Network

Degraded performance from 8:15 PM to 11:36 PM

IMSI Source 02

Degraded performance from 8:15 PM to 11:36 PM

IMSI 01-02

Degraded performance from 8:15 PM to 11:36 PM

Updates
  • Resolved
    UTC
    Resolved

    The incident has been resolved

  • Update
    UTC
    Update

    Update:We are observing a significant improvement in 4G registration performance in the EU1 region. Our teams will continue to closely monitor the situation to ensure stability before declaring the issue fully resolved.

  • Update
    UTC
    Update

    Update:Our service provider is experiencing major infrastructure issues. At this time, we do not yet have an estimated time for resolution.

  • Update
    UTC
    Update

    Update:Our service provider is actively working to resolve the issue. At this time, we do not yet have an estimated time for resolution.

  • Investigating
    UTC
    Investigating

    Dear Valued Customer, We are writing to inform you that we are currently experiencing a service degradation, impacting EU1 (TIS) IMSI profiles. This service degradation is affecting registrations and data sessions with EU1 IMSI profile, and the issue is investigated by our connectivity provider. SIMs that have active IMSIs other than EU1 have not been affected. Impacted Services:New 4G data sessions and registration with EU1 IMSI profiles Posted: 20/03/2026 15:30 GMT-5