Started over 2 years agoFebruary 23, 2024Lasted about 2 hoursFebruary 23, 20249:1711:05 AMUTC
Updates
Resolved
UTC
Resolved
UTC
The scheduled maintenance has been completed.
Update
UTC
Update
UTC
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Investigating
UTC
Investigating
UTC
We will be undergoing maintenance during this time. We don't expect service degradation during the activity.
This scheduled maintenance affects: IMSI 23 (Data Services NA).