Started over 1 year agoJanuary 10, 2025Lasted about 20 hoursJanuary 10, 20257:50 PMJanuary 11, 20254:10 PMUTC
Updates
Resolved
UTC
Resolved
UTC
The incident has been resolved
Investigating
UTC
Investigating
UTC
Dear Customers,
Our IMSI 23-01 MNO partner has confirmed that the service degradation is now in the recovery phase, and they are monitoring improvements.
We will keep you updated