Started over 2 years agoFebruary 23, 2024Lasted about 1 hourFebruary 23, 202412:161:37 PMUTC
Updates
Resolved
UTC
Resolved
UTC
Maintenance complete.
Update
UTC
Update
UTC
Scheduled maintenance is currently in progress.
Investigating
UTC
Investigating
UTC
Scheduled maintenance is currently in progress. We will provide updates as necessary.
This scheduled maintenance affects: IMSI 10 (SMS Services), IMSI 21 (SMS Services), IMSI 22 (SMS Services), IMSI 23 (SMS Services), IMSI 26 (SMS Services).