Started over 3 years agoFebruary 27, 2023Lasted about 2 hoursFebruary 27, 20234:036:01 PMUTC
Updates
Resolved
UTC
Resolved
UTC
Maintenance complete.
Update
UTC
Update
UTC
Maintenance in progress.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Investigating
UTC
Investigating
UTC
This scheduled maintenance affects: IMSI 21 (Data Services NA).
We will be undergoing maintenance at this time. There could be connectivity intermittence while completing the tasks.